Category: Appsmith Support

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Application crash on edit/launch (?after updating v1.7.1 -> v1.7.8)


I encountered a problem when attempting to edit or launch my app, resulting in a crash page with the message "Oops! Something went wrong." After upgrading my appsmith server from v1.7.1 to v1.7.8 and making changes locally and on the remote production server, I suspected the cause might be due to a new organizationId field added to almost every file after the update. Although the issue was initially resolved by reimporting the app from the repository, the error continued to persist on version 1.7.10. With help from the team, we identified the root cause as an error that occurs in rare cases involving the use of a theme, GitRepo, and deleted branches. I ultimately resolved the issue by restoring my server from a backup and applying the classic theme, merging all branches to master and deleting all old branches.


The user experienced a crash on an Appsmith app when trying to edit or launch it, which occurred after they upgraded their server from v1.7.1 to v1.7.8. They suspected that the cause was a new organizationId field added to almost every file after the update. The user tried importing the app from the repository again, but the error recurred, making their normal development process impossible.

The Appsmith team investigated the issue and suspected that a mismatch in version caused the app to crash. They suggested downgrading the server, restoring the app to its previous state before the upgrade, and reimplementing the new features. After restoring the server from a backup, the user applied the classic theme and merged all branches to master, deleting all old branches. They faced challenges several times, but in the end, all worked fine with the classic theme.

Later, the Appsmith team revealed that the error was a known bug and had been fixed. However, the error recurred again on 1.7.10 due to a rare case of using a theme, GitRepo, and a deleted branch. Finally, the user restored the server from the backup and pulled the latest changes of the master branch to fix the issue.