Category: On Prem

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Appsmith v1.7.13 - Cannot connect MySQL datasource, refuses to connect with password


I'm testing out Appsmith in a Docker and trying to connect a MySQL database but it's not using the password I entered. When I try to test it, it says 'using password: NO' and fails. I've tried different MySQL instances and re-installing Appsmith but the issue persists. The error in the log is '[1045] [28000] Access denied for user 'root'@'' (using password: NO)'. Any assistance or ideas would be helpful.


The user has been experiencing an issue while connecting a MySQL database with Appsmith. Despite entering the password, it is not being used to connect to the database, resulting in a failed connection. The user has tried reinstalling Appsmith and connecting to multiple MySQL instances but couldn't resolve the issue.

An Appsmith support team member suggested setting a new password for the user and checking the version of MySQL being used. Appsmith supports MySQL versions 5.5, 5.6, 5.7, and 8.0. So, the user can try setting a new password and verifying the MySQL version to fix the issue.