Category: How do I do X?

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Check to see if Google Maps API integration was successful


I have a self-hosted docker installation of Appsmith and I followed the instructions to configure Google Maps API key. However, even after configuring it, the Map widget is still showing "Map Widget disabled". I tried troubleshooting by looking at the backend log and API key configuration, but couldn't find any solution. I even added IP address restrictions and checked the OAuth consent screen, but it didn't help. Later, I realized that there was already a line for APPSMITH_GOOGLE_MAPS_API_KEY in the docker.env file that was being invalidated by the line I added. So, the issue was resolved by correcting the API key configuration in the correct line.


The user was trying to enable the Map widget on their self-hosted docker installation of Appsmith. They followed the instructions to configure Google Maps API key but still received the error "Map Widget disabled". They tried troubleshooting by checking the backend log of the container but didn't find any relevant information.

After discussing with Appsmith support, it was revealed that the issue was due to duplicate entries of APPSMITH_GOOGLE_MAPS_API_KEY in the docker.env file. The user had added a new line with the API key but there was already an existing line in the file without the key filled in. As a result, the later line was invalidating the earlier line and causing the Map widget to be disabled.

The solution was to remove the duplicate entry and ensure that only one line contained the correct API key. After making the changes and restarting the instance, the Map widget was successfully enabled and working as expected.