Category: Appsmith Support

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

GitHub Private Repo: Getting Invalid remote: origin


I created a private repo in our organization and added an SSH deploy key with write permissions. However, when trying to connect I received a Git configuration error stating that the remote origin was invalid. Upon further investigation, it appears that the RSA keys being generated are SHA-1 which is no longer allowed. I have tried cloning the repo locally with no issues but cannot connect to it. I have been advised to try using the ECDSA key instead.


The problem encountered by the user was due to using an RSA key with SHA-1, which is no longer allowed by GitHub. The user had added an SSH (RSA) deploy key with write permissions and tried to connect to a newly created private repo in the organization. However, they were unable to connect and received an error message indicating an invalid remote: origin.

To resolve the issue, it was recommended to switch to the ECDSA key option instead of RSA. The user was advised to generate and add an ECDSA deploy key to their GitHub account and use it to connect to the private repository.

After adding the ECDSA key, the user was able to connect to the private repo without any issues. It is important for users to ensure that they are using the correct key type supported by GitHub to avoid any errors or configuration issues.