Category: Appsmith Support

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Import from Github repo is taking too much time


I am trying to import a git repository into my Appsmith workspace but it is taking forever to complete and ultimately showing a 504 gateway timeout error. I am self-hosting on AWS AMI and running version 1.9.12 Community. I have checked the console and there are errors appearing. I have also tried refreshing the window, but the imported app is still not showing up. I have shared a screenshot of the error and retrieved the server logs to help investigate the issue.


The user is experiencing issues while importing a git repository into a new workspace in Appsmith. The import process seems to be taking forever and never completes. The user followed the steps mentioned in the official documentation for importing from the repository.

Upon further inquiry, it was found that the user is self-hosting Appsmith using AWS AMI and running version 1.9.12 Community. The import process was giving a 504 gateway timeout error, which was visible in the console.

The support team suggested sharing the screenshot of the error and server logs to investigate the issue further. They also shared the command to get the logs using Docker. The user was advised to check if refreshing the window could show the imported app as sometimes the API times out, but the app is still imported.

As of now, there is no clear solution to the problem, and further investigation is required based on the logs and error messages shared by the user.