Category: Data Source

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Oauth2 - client credentials to oracle rest api , Execution failed with status 4000


I was having trouble using OAuth2 - Client Credentials to connect to my datasource through a RESTful API. The error message said, "Execution failed with status 4000: Invalid authentication credentials. Please check datasource configuration." I couldn't figure out why, even though I was able to successfully connect using basic authentication. After seeking help from the Appsmith community, it turns out there was a bug in Appsmith that was causing the problem. The team is working on fixing it, but in the meantime, I updated Appsmith to v1.9.6 and the problem was resolved. Auth type with OAuth2 - Client Credentials is now working for me.


The user was experiencing issues with connecting to a datasource using the oauth2-client credentials authentication method in Appsmith. They received an "Invalid authentication credentials" error message. Basic auth worked without any issues.

After investigating the issue, it was discovered that it was a bug in Appsmith. However, the bug was only loosely related to the user's issue. The access token URL and other settings were checked, but the problem persisted.

Two potential solutions were suggested. The user could update their Appsmith version to the latest, which they successfully did and resolved the issue. The second solution was to use Ngrok to expose the port they wanted.

In the end, updating the Appsmith version solved the problem, and the user was able to successfully connect to their datasource using the oauth2-client credentials authentication method.