Category: Question and Answers

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Passing only numbers into a string field actually sends a number to the api instead of a “number” string


I am using version v1.7.10 of Appsmith and trying to pass a string containing just numbers in a mustache expression, but it always casts back to some number type even after disabling both options. The value is sent as a number instead of a string to the API, which returns an error. I tried it with postman-echo API and verified that I was enclosing the value with double quotes and had smart substitution turned off. After discarding the changes and trying again, it finally worked.


The user was having an issue with Mustache expressions in Appsmith. They were trying to pass a string containing just numbers to their API, but it was being sent as a number instead of a string. They had already tried disabling smart substitution and enclosing the value with double quotes, but it was not working.

After reviewing the issue with the user and demonstrating how it should work with Postman-echo API, we determined that the user was doing everything correctly. However, upon trying again, the issue was resolved, and the value was sent as a string instead of a number.

Therefore, the solution is to disable smart substitution and enclose the value with double quotes. If this does not work initially, try discarding the changes and making the change again.