Category: Data Source

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Queries timing out


I am having trouble executing MySQL queries on Appsmith as they keep timing out. I am trying to insert/update single records at a time, but even after around 15 seconds the query times out. I have tried adding single quotes around values and the same query has been working fine for the past 6 months. This has become an urgent priority as it stopped working suddenly. I need help from Appsmith support and can share the query details with them for a closer look.


The user is encountering timeouts while running MySQL queries on Appsmith. They have tried executing single records at a time and have also added single quotes around the values being inserted/updated but the issue persists. The query has been running for the past six months and started encountering timeouts only in the last two days.

Appsmith support suggests inviting them to the app as a developer so they can take a closer look at the query and identify if any adjustments are needed. They also inquire if there were any recent updates to the instance.

No solution has been provided yet, but the user is urged to provide more information like the query itself and any recent updates to the instance.