Validation Failure on json file import attempt

Good day! My attempts to import JSON files exported from working Appsmith instances all result in the following (via browser developer tools):

code: 4028
errorType: “INTERNAL_ERROR”
message: “Validation Failure(s): invalid json file”

I could understand if Appsmith version differences were the culprit, but I exported and then attempted to reimport an unadulterated “My first application” and received the same error.

Present versions:
online: v1.8.14-SNAPSHOT
on prem: v1.8.15

Please advise. Thank you!

@ bfegley, thanks for reporting this. Just to clarify, is it the on prem, v1.8.15 that is having issues with imports? Can you import the same file successfully on our cloud?

Happy New Year, @GreenFlux! I’m receiving validation failures for both “Appsmith v1.8.14-SNAPSHOT” (your cloud, “online”) and “Appsmith Community v1.8.15” (Docker container, on prem). I’m unable to import any application that I export from these environments to the same environment or across environments.

Frankly, I never had success with Appsmith’s export/import feature, which is one reason I’ve been using the mongodump/mongorestore (database migration) route. However, with the update to v1.8.15, even database migration seems to be problematic, which is why I decided to re-examine application export/import. Bottom line, I’m just looking for a reliable “version proof” (non-breaking) application backup/restore process. I had been following the guidance at Migrate Applications | Appsmith.

@bfegley can you please share the application json file to debug this further. If this contains the sensitive data you can DM me the file or share it on support@appsmith.com?

@bfegley we received your private message. Could you please send us the file to support@appsmith.com via email? This would help us debug the issue.

Good day, @Amelia! I sent you files for debugging on January 11 to the address you provided. Please advise if you did not receive them. Thank you!

Hello @bfegley! I could not find the files. Can you send them again and add the link to this post for reference?