Category: Data Source

This solution is summarized from an archived support forum post. This information may have changed. If you notice an error, please let us know in Discord.

Google Sheets not finding all sheets


I'm trying to use Appsmith for the first time and comparing it to Retool. When I add Google Sheets and try to create a query, not all sheets are showing up. I expected to be able to use a URL to specify the sheet, but there's only a dropdown list which doesn't show all my sheets. Even when searching for a specific sheet, it doesn't show up. The sheet is in a Shared Drive, which may be causing the issue. I eventually figured out that I could use the JS option to paste the full URL in, but I'm wondering why it's labeled as JS when it just expects a URL.


The user was having trouble accessing a Google Sheet in AppSmith and was unable to see all the sheets in the dropdown menu. They were also unable to use the sheet URL or ID to specify the sheet they wanted to work with. After some investigation, the issue was found to be related to the sheet being located in a Shared (company) Drive.

To solve the issue, the user was advised to choose the JS option and paste the full Google Sheet URL in the box. This worked, and the user was able to access the Google Sheet and use it in their query.

It was explained that the JS option is also available in case the user wants to dynamically build the URL using AppSmith's mustache syntax ({{}}). However, in this case, simply pasting the full URL worked.